Domain Search issue

Incident Report for Rebrandly

Resolved

This incident has been resolved.
Posted Jul 27, 2022 - 18:05 UTC

Investigating

We are aware of an issue affecting Domain Search, making it impossible to verify availability of domain names for purchase
Posted Jul 27, 2022 - 16:42 UTC
This incident affected: Rebrandly Dashboard.