Login issues Chrome extension
Incident Report for Rebrandly
Postmortem

As of now, all login issues affecting Chrome extension are addressed by the the v 4.1.3 in the Chrome Web Store.

Your Chrome browser should have already downloaded this version containing the fix, if not click on the above link to perform the update.

Posted Oct 04, 2021 - 11:15 UTC

Resolved
Login issues Chrome extension
Posted Sep 28, 2021 - 11:12 UTC