Dashboard usability issue
Incident Report for Rebrandly
Resolved
This incident has been resolved.
Posted 3 months ago. May 16, 2019 - 17:17 UTC
Update
Back to normal. Issue has been fixed and affected accounts have been activated to enable the Dashboard experience.
Posted 3 months ago. May 16, 2019 - 17:16 UTC
Identified
We are aware of issues with new Rebrandly FREE accounts registered today and the official Dashboard. In particular, no Workspace is available after first login, making the link creation impossible without an explicit Account activation (under Account Settings menu).

Issue has been solved for new registrations, we are in the process of restoring the usability for accounts registered in last few hours.

Workaround to the issue: activating the account with the wizard in Account Settings - Subscription solves it.
Posted 3 months ago. May 16, 2019 - 16:30 UTC
This incident affected: Rebrandly Dashboard.