Elevated DNS resolution failures on customer domains

Incident Report for Rebrandly

Resolved

Our DNS provider has restored the hosted DNS service, and we have verified that domain names registered via Rebrandly are resolving normally again. Links and QR codes on these domains are working. If a specific domain still does not open for you, it is most likely lingering DNS cache and should clear typically within an hour, and in rare cases up to a few hours depending on your network's DNS provider. We will publish a review of this incident after we complete our follow-up with the provider.
Posted Aug 11, 2026 - 23:26 UTC

Update

Recovery continues to progress. The majority of affected domains are resolving again, and we expect the remainder to follow shortly as caching clears across the internet. Our team is actively verifying restoration across affected domains. We will confirm full resolution here as soon as it's been verified.
Posted Aug 11, 2026 - 22:09 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 11, 2026 - 22:08 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 11, 2026 - 22:02 UTC

Monitoring

Our DNS provider has begun restoring service. Domain names registered via Rebrandly are progressively starting to resolve again. Because DNS answers are cached across the internet, individual domains can take up to an hour after restoration to work for all visitors. We are verifying recovery across affected domains and will confirm full resolution here.
Posted Aug 11, 2026 - 19:58 UTC

Update

We continue to work with our third-party DNS provider to resolve the DNS resolution issue affecting domain names purchased through Rebrandly. The provider currently expects services to begin resolving in the next hour. We will confirm here as soon as service is restored, or sooner if anything changes.
Posted Aug 11, 2026 - 19:39 UTC

Identified

We have identified elevated DNS resolution failures affecting a large portion of domains purchased through Rebrandly. Affected domains, and any short links on them, may not resolve for visitors during this time.

Domains not purchased through Rebrandly, and our core rebrand.ly and rb.gy links, are not affected.

The issue originates with a third-party DNS hosting provider. They have identified the cause and are working on a fix. We will post an update as soon as we have more information.
Posted Aug 11, 2026 - 19:04 UTC
This incident affected: Branded Links redirect (Domain Names registered via Rebrandly).