Data Processing Delays - Rebrandly clicks tracking affected

Incident Report for Rebrandly

Resolved

This incident has been resolved.
Posted Apr 04, 2023 - 11:32 UTC

Investigating

Our data processing infrastructure is running behind, causing delays in the reporting tools.
Posted Apr 04, 2023 - 07:53 UTC
This incident affected: Rebrandly clicks tracking.