Rebrand.ly links not redirecting on Chrome
Incident Report for Rebrandly
Resolved
Starting 2022-05-02, some customers using the Google Chrome browser experienced certificate validation errors relating to certificate transparency logs for rebrand.ly domain name. The issue appear to be depending on latest Chrome release and the GoDaddy team (trusted issuer of our SSL certificate) is working on a patch. In the meanwhile, we managed to install an alternative SSL certificate via Amazon Certificate Manager to restore the redirection.
Posted May 03, 2022 - 00:10 UTC
Investigating
We are investigating reports of invalid certificate errors for rebrand.ly links (error ERR_CERTIFICATE_TRANSPARENCY_REQUIRED). Chrome users are affected and other browsers appear unaffected at the moment.
Posted May 03, 2022 - 00:05 UTC
This incident affected: Generic short URLs redirect.