HTTPS redirection issues: revoked certificate
Incident Report for Rebrandly
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 19:48 UTC
Update
We are aware that, following our resolution announce, there were spare cases where the domain name certificate was issued with delay with respect to the original expectations, or was not issued at all. After a deeper investigation, we observed that today's revocation of a set of SSL certificates uncovered a possible new integration issue between Let's Encrypt and CloudFlare systems. Specifically, customers using proxy services to route their links traffic might be experiencing additional issues at getting their https redirection working again without warnings. We have observed that disablling the active proxy, or alternatively degrading the communication protocol from HTTPS to HTTP for the channel between the Proxy and the Host (Rebrandly) helped exiting this scenario. We will investigate this specific regression outside of the context of this incident.
Posted Oct 14, 2021 - 19:48 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 14, 2021 - 11:48 UTC
Update
HTTPS redirection for affected domain names which were registered via Rebrandly is now fully operational. Monitoring the issuance of SSL certificates for affected domain names which were connected to Rebrandly via DNS.
Posted Oct 14, 2021 - 10:36 UTC
Monitoring
We are monitoring progress as domain names certificates are generated for the affected domains.
Posted Oct 14, 2021 - 01:27 UTC
Update
We inform you that this issue does not affected Generic short URLs redirect (links with rebrand.ly or rb.gy domain name).
Posted Oct 13, 2021 - 22:26 UTC
Update
A patch is on the go, as we re-issue the revoked SSL certificates for affected domain names. We are in touch with the Let's Encrypt team to reduce the impact of this inconvenience at the best of our possibilities.
Posted Oct 13, 2021 - 22:25 UTC
Identified
We are experiencing downtime in HTTPS redirection due to an abrupt revoke of a number of SSL certificates which were generated by Let's Encrypt Certificate Authority. We are in the process of re-generating SSL certificates to restore redirection. Link redirection for customers with Custom SSL certificates is not affected.
Posted Oct 13, 2021 - 21:15 UTC
This incident affected: Branded Links redirect (Domain Names registered via Rebrandly), Branded Links redirect (Domain Names managed outside Rebrandly), and Generic short URLs redirect.