Dashboard login issues
Incident Report for Rebrandly
Resolved
The login issue has been resolved.
Posted Apr 28, 2024 - 06:06 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 27, 2024 - 19:30 UTC
Investigating
We are currently investigating on login issues. Link redirection and tracking are not affected.
Posted Apr 27, 2024 - 18:31 UTC
This incident affected: Rebrandly Dashboard.