Domains registration
Incident Report for Rebrandly
Resolved
The issue has been resolved, thanks for your patience.
Posted about 1 year ago. Mar 30, 2016 - 13:20 UTC
Monitoring
Due to some issues in our upstream provider, domain registration could have some errors, we're monitoring and working to solve this issue.
Posted about 1 year ago. Mar 30, 2016 - 12:51 UTC